[ivtv-users] Audio gone?

Andy Walls awalls at radix.net
Sat Feb 20 20:20:10 CET 2010


On Fri, 2010-02-19 at 12:24 +0900, David Pimentel wrote:
> Thank you for responding!
> 
> I couldn't get a pcm stream from video24 (nothing streaming, makes 0b
> files),

So the audio clocks are not working or something along that line then
(like the analog audio to I2C audio digitizer chip is not working).


>  but video32 gave me the most interesting, rhythmic noise.
> Trent Reznor would remix it into something amazing.

That's raw YUV video (only) in a Conexant specific format.  It may have
sounded interesting when shoved through aplay, but you'll never hear the
TV program audio doing that. ;)


> Obviously, it encoded something other than silence, but I don't have
> any idea what it tried to encode. xxd ouput a lot of random hex.
> 
> I also tried "cat /dev/video0 > foo.mpeg" which produced a video
> stream with no audio. I also put that through aplay (maybe no such a
> good idea...) only to hear a magnificent hiss.


$ mplayer foo.mpeg

would play back both audio and video in the MPEG file.  aplay wouldn't
know how to parse an MPEG file.


> Status Log: # While inactive
> 
>    [ 1574.986972] ivtv0: =================  START STATUS CARD #0
> =================
>    [ 1574.986981] ivtv0: Version: 1.4.1 Card: I/O Data GV-MVP/RX,
> GV-MVP/RX2W (dual tuner)
>    [ 1574.986991] ivtv0: GPIO status: DIR=0xc301 OUT=0x0200 IN=0x121e
>    [ 1574.986996] saa7115 2-0021: Audio frequency: 48000 Hz
>    [ 1574.988810] saa7115 2-0021: Input:           S-Video 0
>    [ 1574.988814] saa7115 2-0021: Video signal:    broadcast/DVD
>    [ 1574.988818] saa7115 2-0021: Frequency:       60 Hz
>    [ 1574.988822] saa7115 2-0021: Detected format: NTSC
>    [ 1574.988826] saa7115 2-0021: Width, Height:   720, 480
>    [ 1574.988833] tda9887 2-0043: Data bytes: b=0xd0 c=0x6d e=0x40
>    [ 1574.988839] tuner 2-0060: Tuner mode:      analog TV
>    [ 1574.988844] tuner 2-0060: Frequency:       307.25 MHz
>    [ 1574.988848] tuner 2-0060: Standard:        0x00002000
>    [ 1574.991173] upd64031a 2-0012: Status: SA00=0x02 SA01=0x01
>    [ 1574.996042] upd64083 2-005c: Status: SA00=40 SA01=ff SA02=00
> SA03=00 SA04=0f SA05=00 SA06=00
>    [ 1574.996049] vp27smpx 2-005b: Audio Mode: 1


There are no status messages from the wm8739 driver.  The WM8739 chip is
what converts analog audio to digital audio.

Please try these to see if the ivtv driver was able to load the wm8739
driver:

$ /sbin/lsmod | grep wm8739

... or if you even have the module built:

$ /sbin/modinfo wm8739
filename:       /lib/modules/2.6.27.30-170.2.82.fc10.x86_64/kernel/drivers/media/video/wm8739.ko
license:        GPL
author:         T. Adachi, Hans Verkuil
description:    wm8739 driver
srcversion:     E4A65D54DB800B29C82E385
alias:          i2c:wm8739
depends:        i2c-core,v4l2-common,videodev
vermagic:       2.6.27.30-170.2.82.fc10.x86_64 SMP mod_unload 
parm:           debug:Debug level (0-1) (int)


Also during the load of the ivtv driver for this card, the driver should
have emitted something like this:

wm8739 2-001a: chip found @ 0x34 (ivtv i2c driver #0)


What does the output of dmesg show or what does /var/log/messages have
in it when the ivtv driver is loaded?

Unfortunately these is very little built-in debugging to se what may be
going wrong with the initialization of this chip.  If it is not getting
loaded, I'll have to provide an ugly patch to you so we can get more
visibility into where the wm8739 initialization is failing.  (Or you can
just add printk()'s to ivtv-driver.c:ivtv_load_and_init_modules() and
ivtv-i2c.c:ivtv_i2c_register(), if you're up to it.)

Regards,
Andy




More information about the ivtv-users mailing list