[ivtv-users] recent work with HVR-1600 irblaster?

Andy Walls awalls at md.metrocast.net
Sat Apr 3 02:17:38 CEST 2010


On Thu, 2010-04-01 at 15:26 -0600, James Grossmann wrote:
> On Wed, Mar 31, 2010 at 5:52 AM, Andy Walls <awalls at md.metrocast.net> wrote:

> > Some simple thing for you to try:
> >
> > 1. Check the IR receveir transmitter cable.  Twice in the past I myself
> > have failed to push it in the socket all the way.  IR will not work
> > without the cable pushed into the socket fully.
> >
> > 2. Load the ir-kbd-i2c module with the debug=2 option.  That will give
> > you verbose debugging on IR keypresses from the microcontroller, even if
> > they fail to make it to the input subsystem and show up on the screen.
> >
> > 3.  With the modules loaded, use cx18-ctl (from the v4l-apps in the
> > source tree) to reset the IR microcontroller:
> >
> >        $ cx18-ctl -d /dev/video0 --reset 1
> >
> > and see if it starts responding.
> >
> > 4. Look under /lib/modules for duplicates of the cx18.ko and
> > ir-kbd-i2c.ko and other ir related modules.  There was a time (and maybe
> > there still is), when Ubuntu had modules in a non-standard location that
> > the v4l-dvb build system didn't know about.  In other words, make sure
> > you're not loading older modules or mixing modules.
> >

> Thank You! It does seem to have worked, I twisted the cable in the
> plug a fair amount and it started to display numbers/codes when I
> pushed buttons on the remote!  At first, I didn't see it, because I am
> sshing into the machine, but I was getting notes of keypresses in
> dmesg (using debug=2), so I thought I'd check again, and twisting it
> seems to have fixed it.

Good.  

I had once wasted about 3 hours of debugging code when I first ran
across the "oops I didn't push the cable in all the way" bug. :)



>   I was at the point of downloading the
> v4l-apps, but I couldn't find something with the cx18-ctl util in it.
> Were you referring to the I downloaded the dvd-apps tip.tar.bz2, from
> http://linuxtv.org/hg/dvb-apps/, but no cx18-ctl, I searched
> ivtvdrivers.org, but no reference.  I'm just curious where I would
> have found them.

Mea culpa.  They were recently moved out of the driver tree into their
own git repository:

http://git.linuxtv.org/v4l-utils.git

http://git.linuxtv.org/v4l-utils.git?a=tree;f=utils/v4l2-ctl;h=9c40b0506a44a9640eda38bb48360d65f6f910f7;hb=HEAD



> I'm also curious, now that I've got receive (which I wasn't worried
> about), how do I get transmit?

Unload ir-kbd-i2c, and use lirc_dev, lirc_zilog (or lirc_pvr150) and all
of the lirc userspace tools.

Regards,
Andy

> Thanks again,
> James





More information about the ivtv-users mailing list