[ivtv-users] sound but no video (almost)

Scott Thurmond kenpoma at yahoo.com
Wed Oct 11 17:22:41 CEST 2006


I guess my real question is how to get the tuner to
show video?  Any ideas?  Here is the output from ivtv
-a

ioctl IVTV_IOC_G_CODEC ok
Codec parameters
aspect      : 2
audio       : 0x00e9
bframes     : 3
bitrate_mode: 0
bitrate     : 4500000
bitrate_peak: 6000000
dnr_mode    : 0
dnr_spatial : 0
dnr_temporal: 8
dnr_type    : 0
framerate   : 0
framespergop: 15
gop_closure : 1
pulldown    : 0
stream_type : 0
ioctl VIDIOC_G_FMT ok
	Type   : Video Capture
	Width  : 480
	Height : 480
ioctl VIDIOC_QUERYCAP ok
	Driver name   : ivtv
	Card type     : Hauppauge WinTV PVR-150
	Bus info      : 0000:05:04.0
	Driver version: 1793
	Capabilities  : 0x01030051
ioctl: VIDIOC_ENUMINPUT
	Input   : 0
	Name    : Tuner 1
	Type    : 0x00000001
	Audioset: 0x00000007
	Tuner   : 0x00000000
	Standard: 0x000000000000B000 ( NTSC )
	Status  : 0

	Input   : 1
	Name    : S-Video 1
	Type    : 0x00000002
	Audioset: 0x00000007
	Tuner   : 0x00000000
	Standard: 0x0000000000FFFFFF ( PAL NTSC SECAM )
	Status  : 0

	Input   : 2
	Name    : Composite 1
	Type    : 0x00000002
	Audioset: 0x00000007
	Tuner   : 0x00000000
	Standard: 0x0000000000FFFFFF ( PAL NTSC SECAM )
	Status  : 0

	Input   : 3
	Name    : S-Video 2
	Type    : 0x00000002
	Audioset: 0x00000007
	Tuner   : 0x00000000
	Standard: 0x0000000000FFFFFF ( PAL NTSC SECAM )
	Status  : 0

	Input   : 4
	Name    : Composite 2
	Type    : 0x00000002
	Audioset: 0x00000007
	Tuner   : 0x00000000
	Standard: 0x0000000000FFFFFF ( PAL NTSC SECAM )
	Status  : 0
ioctl VIDIOC_G_INPUT ok
Video input = 0
ioctl: VIDIOC_ENUMOUTPUT
ioctl VIDIOC_G_OUTPUT failed: Invalid argument
ioctl: VIDIOC_ENUMAUDIO
	Input   : 0
	Name    : Tuner 1

	Input   : 1
	Name    : Line In 1

	Input   : 2
	Name    : Line In 2
ioctl VIDIOC_G_AUDIO ok
Audio input = 0: Tuner 1
ioctl VIDIOC_G_FREQUENCY ok
Frequency = 884
ioctl: VIDIOC_ENUMSTD
	index       : 0
	ID          : 0x000000000000000F
	Name        : PAL-BGH
	Frame period: 1/25
	Frame lines : 625

	index       : 1
	ID          : 0x00000000000000E0
	Name        : PAL-DK
	Frame period: 1/25
	Frame lines : 625

	index       : 2
	ID          : 0x0000000000000010
	Name        : PAL-I
	Frame period: 1/25
	Frame lines : 625

	index       : 3
	ID          : 0x0000000000000100
	Name        : PAL-M
	Frame period: 1001/30000
	Frame lines : 525

	index       : 4
	ID          : 0x0000000000000200
	Name        : PAL-N
	Frame period: 1/25
	Frame lines : 625

	index       : 5
	ID          : 0x0000000000000400
	Name        : PAL-Nc
	Frame period: 1/25
	Frame lines : 625

	index       : 6
	ID          : 0x00000000000D0000
	Name        : SECAM-BGH
	Frame period: 1/25
	Frame lines : 625

	index       : 7
	ID          : 0x0000000000320000
	Name        : SECAM-DK
	Frame period: 1/25
	Frame lines : 625

	index       : 8
	ID          : 0x0000000000400000
	Name        : SECAM-L
	Frame period: 1/25
	Frame lines : 625

	index       : 9
	ID          : 0x0000000000800000
	Name        : SECAM-L'
	Frame period: 1/25
	Frame lines : 625

	index       : 10
	ID          : 0x0000000000001000
	Name        : NTSC-M
	Frame period: 1001/30000
	Frame lines : 525

	index       : 11
	ID          : 0x0000000000002000
	Name        : NTSC-J
	Frame period: 1001/30000
	Frame lines : 525

	index       : 12
	ID          : 0x0000000000008000
	Name        : NTSC-K
	Frame period: 1001/30000
	Frame lines : 525
ioctl VIDIOC_G_STD ok
Video standard = 0x0000b000
ioctl: VIDIOC_QUERYCTRL
Brightness = 128
Contrast = 63
Saturation = 63
Hue = 0
Volume = 58880
Balance = 32768
Bass = 32768
Treble = 32768
Mute = 0




--- Keith C <mythtv at keithandjill.com> wrote:

> On Oct 10, 2006, at 10:36 PM, Scott Thurmond wrote:
> 
> > Update -
> >
> > I just noticed that while using the s-video I can
> use
> > the DTV remote and change a channel on the set top
> box
> > and the video changes.
> >
> > When I try to use ivtv-tune -c 206, I get this
> > message:
> >
> > [mythtv at dev ~]$ ivtv-tune -c 206
> > Invalid channel for 'us-cable'
> >
> > But, I am not using us-cable.  Are there other
> > options?
> 
> Since you're watching the s-video input, you can not
> change channels  
> locally (the DTV box is only sending one channel). 
> To change the  
> channel, you'll need a channel changing script and a
> method of  
> connecting your Myth box to the DTV tuner (serial
> cable or the  
> like).  This is covered in the MythTV wiki, although
> your success  
> will depend greatly on the model number of your DTV
> tuner.
> 
> Keith C
> 
> >
> > -Scott
> >
> > --- Scott Thurmond <kenpoma at yahoo.com> wrote:
> >
> >> Over the last week I have put together a myth box
> >> with
> >> a few issues.
> >>
> >> The first is that I cannot get video from the
> tuner.
> >>
> >> I do, however, get sound from the tuner.
> >>
> >> I get video from the s-video input though.
> >>
> >> I have read through the mail archives and googled
> >> trying different configurations, options, etc.
> >>
> >> Being a newbe, I am not really sure where to
> start
> >> looking.
> >>
> >> Here is what I have:
> >>
> >> PVR-150
> >> Directv (US)
> >> I used Jarod Wilson's guide to install on a FC5
> >> system.
> >> Using cat /dev/video0 > /tmp/test_capture.mpg
> >> produces
> >> a file where I can hear the audio from a channel
> but
> >> the video is scrabled.
> >>
> >> Switching to the s-video, I get video.
> >>
> >> I feel like I am close but not really sure what
> to
> >> try
> >> next.
> >>
> >> Any ideas are welcome.
> >>
> >> -Scott
> >>
> >>
> __________________________________________________
> >> Do You Yahoo!?
> >> Tired of spam?  Yahoo! Mail has the best spam
> >> protection around
> >> http://mail.yahoo.com
> >>
> >> _______________________________________________
> >> ivtv-users mailing list
> >> ivtv-users at ivtvdriver.org
> >> http://ivtvdriver.org/mailman/listinfo/ivtv-users
> >>
> >
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Tired of spam?  Yahoo! Mail has the best spam
> protection around
> > http://mail.yahoo.com
> >
> > _______________________________________________
> > ivtv-users mailing list
> > ivtv-users at ivtvdriver.org
> > http://ivtvdriver.org/mailman/listinfo/ivtv-users
> 
> 
> _______________________________________________
> ivtv-users mailing list
> ivtv-users at ivtvdriver.org
> http://ivtvdriver.org/mailman/listinfo/ivtv-users
> 


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 



More information about the ivtv-users mailing list