[ivtv-users] Problem with installing an Adaptec AVC-2410 on Fedora 4

Trev Jackson trev.email at btinternet.com
Mon Apr 10 11:23:04 CEST 2006


Hi Thomas,

Yes, after thinking about it I realised the earlier version of ivtv would have 
worked, but the sound would be badly distorted because the difference between 
the PVR250 which it was defaulting to and the AVC-2410 is that the AVC-2410 
has a CS53L32A DAC that needs setting to the correct sampling speed.
I think the later version of ivtv requires the firmware to be in a different 
location to the earlier versions, which may explain why it worked before but 
doesn't now.

There are other people on this list also running Fedora Core 4 and they will 
be able to let you know where to put the hotplug firmware files for your 
distro.

Best Regards

Trev

On Sunday 09 Apr 2006 23:34, Thomas Strike wrote:
> Thomas Strike wrote:
> >Trev Jackson wrote:
> >>Hi Thomas,
> >>
> >>The message log shows the version of ivtv that you are running is 0.3.8
> >> and I am sorry to say that 0.3.8 does not support the AVC-2410.
> >>
> >>I believe that the reason for this is because you have an old version of
> >> the ivtv modules on your system which you need to delete and re-run
> >> depmod.
> >>
> >>Best Regards
> >>
> >>Trev
> >
> >This is interesting. I didn't notice the 0.3.8 version ID.  I downloaded
> >and installed ver. 0.4.4.  I didn't think I had an old version on my
> >system. The Irony is that I copied ivtv-fw-enc.bin to /lib/modules/ and
> >it started working (I think).  It is now creating /dev/video0,
> >/dev/video, etc..., and I successfully created a test.mpg file (about 14
> >Meg, 20 seconds worth).  I have no way of looking at the file to see if
> >it's good though because I have no mpeg2 player installed and now I'm
> >having problems with installing "mplayer".
> >
> >Thanks again,
> >Tom
> >
> >I will, however, Remove the 0.3.8 version and try 0.4.4 again in any
> > event.
>
> I now have ver. 0.4.4 installed and everything looks good (cleaned up my
> directories to) but now it's not creating the /dev/video* devices again
> and this time it's looking to load a v4l firmware file. That's where I
> think it's failing.  Below is my newest dmesg extract.
>
> By the way, now it even knows what hardware I'm using. egnore the radio
> tunner found.  I haven't delt with the IRC thing yet.
>
> Thanks,
> Tom
>
> ivtv:  ==================== START INIT IVTV ====================
> ivtv:  version 0.4.4 (tagged release) loading
> ivtv:  Linux version: 2.6.11-1.1369_FC4 686 REGPARM 4KSTACKS gcc-4.0
> ivtv:  In case of problems please include the debug info between
> ivtv:  the START INIT IVTV and END INIT IVTV lines, along with
> ivtv:  any module options, when mailing the ivtv-users mailinglist.
> ivtv0: Autodetected Adaptec VIDEOH! AVC-2410 card (cx23416 based)
> ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LNKB] -> GSI 10 (level,
> low) -> IRQ 10
> cs53l32a 1-0011: ivtv driver
> cs53l32a 1-0011: chip found @ 0x22 (ivtv i2c driver #0)
> ivtv0: i2c attach to card #0 ok [client=cs53l32a, addr=11]
> tuner (ivtv): chip found at addr 0xc0 i2c-bus ivtv i2c driver #0
> All bytes are equal. It is not a TEA5767
> ivtv0: i2c attach to card #0 ok [client=(tuner unset), addr=60]
> tuner (ivtv): chip found at addr 0xd6 i2c-bus ivtv i2c driver #0
> ivtv0: i2c attach to card #0 ok [client=(tuner unset), addr=6b]
> saa7115 1-0021: ivtv driver
> saa7115 1-0021: saa7115 found @ 0x42 (ivtv i2c driver #0)
> ivtv0: i2c attach to card #0 ok [client=saa7115, addr=21]
> msp3400 1-0040: ivtv driver
> msp3400 1-0040: chip=MSP3425G-B8 +nicam +simple +simpler +radio
> mode=simpler ivtv0: i2c attach to card #0 ok [client=MSP3425G-B8, addr=40]
> msp3400 1-0040: msp34xxg daemon started
> tda9887 1-0043: (ivtv) chip found @ 0x86 (ivtv i2c driver #0)
> ivtv0: i2c attach to card #0 ok [client=tda9887, addr=43]
> ivtv0: Detected a TEA5767 radio tuner. Enabling radio support.
> ivtv0: unable to open firmware v4l-cx2341x-enc.fw
> ivtv0: did you put the firmware in the hotplug firmware directory?
> ivtv0 warning: failed loading encoder firmware
> ivtv0 warning: Error loading firmware -3!
> ivtv0: Error -3 initializing firmware.
> ivtv0: Error -12 on initialization
> ivtv: probe of 0000:00:09.0 failed with error -12
> ivtv:  ====================  END INIT IVTV  ====================
>
>
>
> _______________________________________________
> ivtv-users mailing list
> ivtv-users at ivtvdriver.org
> http://ivtvdriver.org/mailman/listinfo/ivtv-users



More information about the ivtv-users mailing list