[ivtv-devel] [UNKNOWN CX18 CARD] Toshiba G30-130 laptop

Rene Rask rene at grain.dk
Fri Jan 18 18:46:48 CET 2008


I downloaded and compiled the lastest cx18 driver from 
http://www.linuxtv.org/hg/~hverkuil/cx18/archive/tip.tar.bz2 
<http://www.linuxtv.org/hg/%7Ehverkuil/cx18/archive/tip.tar.bz2> from 
Jan 18.

modprobing ca18 gives me:
[ 6739.052824] Linux video capture interface: v2.00
[ 6739.064445] cx18:  Start initialization, version 0.1.0
[ 6739.064525] cx18-0: Initializing card #0
[ 6739.064531] cx18-0: Unknown card: vendor/device: 14f1/5b7a
[ 6739.064537] cx18-0:               subsystem vendor/device: 1179/0110
[ 6739.064541] cx18-0: Defaulting to Hauppauge HVR-1600 card
[ 6739.064545] cx18-0: Please mail the vendor/device and subsystem 
vendor/device IDs and what kind of
[ 6739.064550] cx18-0: card you have to the ivtv-devel mailinglist 
(www.ivtvdriver.org)
[ 6739.064554] cx18-0: Prefix your subject line with [UNKNOWN CX18 CARD].
[ 6739.064593] ACPI: PCI Interrupt 0000:06:09.0[A] -> GSI 19 (level, 
low) -> IRQ 21
[ 6739.064629] allocation failed: out of vmalloc space - use 
vmalloc=<size> to increase size.
[ 6739.064634] cx18-0: ioremap failed, perhaps increasing 
__VMALLOC_RESERVE in page.h
[ 6739.064638] cx18-0: or disabling CONFIG_HIMEM4G into the kernel would 
help
[ 6739.064643] cx18-0: Error -12 on initialization
[ 6739.064655] cx18: probe of 0000:06:09.0 failed with error -12
[ 6739.064676] cx18:  End initialization

lspci -vvn:
06:09.0 0400: 14f1:5b7a
    Subsystem: 1179:0110
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
    Latency: 64 (500ns min, 50000ns max), Cache Line Size: 32 bytes
    Interrupt: pin A routed to IRQ 21
    Region 0: Memory at f4000000 (32-bit, non-prefetchable) [size=64M]
    Capabilities: [44] Vital Product Data
    Capabilities: [4c] Power Management version 2
        Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA 
PME(D0-,D1-,D2-,D3hot-,D3cold-)
        Status: D0 PME-Enable- DSel=0 DScale=0 PME-

lspci -vv:
06:09.0 Multimedia video controller: Conexant CX23418 Single-Chip MPEG-2 
Encoder with Integrated Analog Video/Broadcast Audio Decoder
    Subsystem: Toshiba America Info Systems Unknown device 0110
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
    Latency: 64 (500ns min, 50000ns max), Cache Line Size: 32 bytes
    Interrupt: pin A routed to IRQ 21
    Region 0: Memory at f4000000 (32-bit, non-prefetchable) [size=64M]
    Capabilities: [44] Vital Product Data
    Capabilities: [4c] Power Management version 2
        Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA 
PME(D0-,D1-,D2-,D3hot-,D3cold-)
        Status: D0 PME-Enable- DSel=0 DScale=0 PME-


This is on Ubuntu using 32bit kernel 2.6.24-2-generic. I have 2 BG ram 
in this machine.
I also tried copying what looks to be the corresponding firmware files 
from the toshiba windows installation. Identical result.
I don't know where to increase the vmalloc as the dmesg suggests.

If there is some way I can provide more information please let me know.

Keep up the great work :)
Rene





More information about the ivtv-devel mailing list