[ivtv-devel] Gentoo patch xdriver 0.10.6 xorg 7.1

Jeff Simpson jeffsimpson at alum.wpi.edu
Wed Feb 7 20:42:20 CET 2007


Hmm, disregard my ebuild. It looks like the ebuild in portage now
works fine. I must have just not been synced up properly when I tested
it and tried to patch myself a new one.

If the gentoo dev is on this list, would it be possible in the future
to have the revision numbers on the ebuilds change if the ebuild
changes? I know 0.10.6 is the ivtv xdriver version, but maybe throw an
r1, r2, r3 on there to reflect the patch set and etc? Only reason I
can tell it changed is that it works now and didn't work before, and
the dependency used to be on xorg-server-1.0.2, and now it needs
1.1.1.

Then again, I still haven't actually checked it on the TV yet, so I
could be just spouting hot air about the one in portage working with
7.1.1 :-P

 - Jeff

On 2/7/07, Jeff Simpson <jeffsimpson at alum.wpi.edu> wrote:
> >
> > Don't know why, but just copy and paste the patch from the Website seems not to
> > work. I attached the patches. The svn patch worked for me.
> >
>
> Ahh, excellent. Thanks!
>
> I got the svn ebuild working, posted it here:
>
> http://www.mit.edu/~je18337/ivtvdev/xorg7.1
>
> emerging the -9999 package will grab the latest SVN and install it. If
> you copy the ebuild to -9999.XXXX.ebuild, it will install svn revision
> #XXXX (I just now installed 3797 as the latest version, and did a
> couple other revisions to test it).
>
> I had to modify the patch you sent to replace "xdriver" with "trunk"
> as that's how it comes from svn in an ebuild, apparently. I also
> included fbpriv.h (from xorg-server-1.1.1) so that it will copy into
> the working directory for the compile and not need to be manually
> copied into /usr/include.
>
> I haven't test the resulting binary driver at all, yet, just tested it
> enough to see that it compiles without any errors.
>
>  - Jeff
>



More information about the ivtv-devel mailing list