[ivtv-devel] app to view plain teletext

Duncan Webb duncan-v4l at linuxowl.com
Thu Feb 23 15:45:31 CET 2006


Hans Verkuil wrote:

>>Hans Verkuil wrote:
>>
>>    
>>
>>>On Wednesday 22 February 2006 12:37, Duncan Webb wrote:
>>>
>>>
>>>      
>>>
>>>>>>count[1]) = 2048 * 1 * (16 + 16).
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>>2048? The samples_per_line is around 1440 (lightly different between
>>>>>the pvr250/350 and pvr150/500).
>>>>>
>>>>>
>>>>>          
>>>>>
>>>>I got confused here, sorry.
>>>>
>>>>Attached is a patch to alevt to use sliced vbi data when the driver
>>>>says it has this capability.
>>>>
>>>>I believe that ivtv-0.4.3 is dropping teletext lines in sliced vbi
>>>>mode. I've updated vbishow and compared the output from bttv and ivtv
>>>>cards running on the same machine and it seems that the ivtv card
>>>>drops a line every 30-40 packets. I'll do some more testing and
>>>>report back.
>>>>
>>>>
>>>>        
>>>>
>>>What PVR card are you using? I've found that the PVR150/500 cards have
>>>more difficulties with sliced VBI then the PVR250/350 cards. I have one
>>>VBI line that the cx2584x cannot recognize half the time (the first
>>>leading pulse of that line is half the height of the other pulses, the
>>>saa7115 of the PVR350 has no problem with that).
>>>
>>>
>>>      
>>>
>>I've two PVR-350 cards, one on a P3 and one on an AMD64 machine. The P3
>>also has a bttv card (Win-TV PCI)
>>
>>    
>>
>>>You can check with osc (from the zvbi library) if you have a similar
>>>problem.
>>>
>>>
>>>      
>>>
>>Attached are two screen shots of osc, one for the bttv card and the
>>other for the ivtv card. They are quite different.
>>    
>>
>
>No, they are the same. The bottom one shows line 6 which is usually empty,
>the top one shows line 7. Just press cursor down in the bottom window to
>go to line 7 and you'll see that they are the same. The only difference is
>that the start pulses are more to the right compared to ivtv. But they are
>still visible, and that's what counts.
>  
>
I see what you mean, but I see why alevt works for you and fails for me 
using raw vbi for the PVR-350 cards.

I guess that there is a bug or two in alevt's vbi handling...

Regards,
Duncan



More information about the ivtv-devel mailing list