[ivtv-devel] Still need help on DMA issues causing MPEG Corruption

Steven Ellis mail_lists at stevencherie.net
Tue Aug 8 23:37:03 CEST 2006


First off can someone setup an account on trac for me so I can update 
tickets 48 and 49.

Now I have been trying ivtv version 0.4.2-0.4.6, plus I've seen recent 
reports of the problem still being present with the 0.6.x tree.

Hardware - Asus A8N-VM CSM motherboard, Athlon 64 3000+, Knoppmyth R5B7 
with 2.6.15 kernel, IDE HD and either PVR150 or PVR500 capture (tried 
both). I also have a FreeCom USB DVB-T card, and I run a lot of media 
over the 100Mb network.

Reproducing the problem
--------------------------------
Can almost do this at will now. If I have a capture running whilst I 
delete a large previously captured file (about 2G) off an ext3 local 
volume the slight system pause during the deletion is enough to force 
the problem.

It also seems to happen quite quickly if I'm playing a video file across 
the network via NFS and jump around the video stream very rapidly. Its 
like the ethernet i/o is preventing the DMA from the ivtv card

Attempts to fix the problem
----------------------------------
1. Turned off Cool and Quiet
This was mentioned in trac ticket 48 as a possible fix. Initially 
appeared to reduce occurrences, but I was mistaken. No change

2. Try to change the PCI latency of the IDE devices with setpci.
Doesn't work with the IDE devices on my motherboard. It uses and nforce 
chipset and the driver won't let you change latency values. The MythTV 
Wiki recommends bumping the IDE latency to avoid issues.

3. Check BIOS level timings etc
Doesn't appear to be anything I can tweak in this bios.

4. Use PIO mode.
Well I just tried this and my machine isn't fast enough to capture full 
D1 PAL in PIO mode. CPU is running 60%+ in ivtv_enc, but I still get 
capture issues.

Possible Next Steps
------------------------
1. Changing the size of the DMA ENC buffers
Any chance increasing the buffer sizes might help matters.

2. Enable additional debug information
This is where I need some feedback. What debug options should I look at 
enabling.


I'd really appreciate any help here. The oddest part is I never had this 
problem with the older 0.3.x driver versions. There are quite a few 
people on this list and the users list with the problem. I'm sure with a 
bit of guidance from Hans we can track it down.

Steve



More information about the ivtv-devel mailing list